Forums General General Chat Spoiler button test

This topic contains 13 replies, has 4 voices, and was last updated by  Mastertrek 6 months ago.

  • #27255
    Zherk01
    Participant

    Lol. Don’t worry, I’m pretty that those scenarios are few and far between. Just my designer OCD kicking.

     

    Just testing image attachment inside a spoiler.


    Spoiler
    Screenshot_20180304-024216

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Justice Chronicles | Unlucky Hero | Fernz Gate | Dragon Lapis

    Disliked: Asdivine Dios | Fairy Elements

    • This reply was modified 6 months ago by  Zherk01.
    #27307
    MSG Commander
    Keymaster

    😉 Well, if I did everything correctly, the forum editor now has a working spoiler button.

    Spoiler
    Just click the word ‘spoiler’ then enter a title (or leave it at the default “Spoiler”, and it’ll still work just fine).

    You can even type out your paragraphs before-hand, and then click ‘spoiler – and it will insert the spoiler tags, whilst still maintaining the highlighted text!

    Which is…
    Which is AWESOME!

    (Now, it doesn’t necessarily jive 100% with standard WordPress coding for editor plugins…. but… as long as it works, we can totes use it!) So somebody please give it a whirl, and let me know what you think. 😎

    It works but…
    Some pages doesn’t render BBCode. For example, in Activity>Mentions there is a post preview, and spoiler BBCode was rendered a simple text. It happens on other feeds too, for example, see my activity by clicking on “Jesusalva” at left. Other than that, it is great! 😀 (Do not think in adding a “tabs” button, I can’t even imagine how that would look. If you want to save more page space, maybe Attachments section could be reworked, so “Submit” button is closer to the textarea.)

    @msg-commander Sorry for not responding earlier, the email just got drowned in an ocean of Gitlab broken pipelines D: License checks are truly annoying pipelines.

    NOOOOOOOOOOOOOOOOOOOOOOOOOOO!!!!!!!!!! Lolz. That was one of the very few things I never thought to test for haha. It is a mobile-only problem, because on my desktop those “Copy Share” etc buttons don’t appear at all. I think I could possibly fix that problem by re-arranging the buttons, and putting spoiler where the list buttons currently reside (but then they would be blocked, but that might not be as big of a problem), or I could try removing some buttons so we still have one line but spoiler is off to the far right – but then if the “Copy Share” buttons appear differently on different phones…. well… I hate to put it on the user, but it might be that the best solution in this scenario (assuming someone wanted to add a spoiler to their first line of text), might be to just cut the text, add the spoiler tags, and then paste the text back in between them? I hate having to offer a solution like that, because it makes more work for the user, but I really can’t see any other solution… (but by and large, it might not be that big of an issue, anyway… depends on how often people want to spoiler that first line of text.) Anyway thanks for bringing it to my attention.

    The QUOTE link is now stripping all paragraph tags (it probably has been, ever since I switched over to this Visual editor, but this is the first time I noticed it). Ignore this whole post as it’s just me quoting various things to prove that, yes, the quote feature is acting fishy…  👿

    Follow us on Facebook, Instagram, and Twitter

    #27310
    MSG Commander
    Keymaster

    😉

    Well, if I did everything correctly, the forum editor now has a working spoiler button.

    Spoiler
    Just click the word ‘spoiler’ then enter a title (or leave it at the default “Spoiler”, and it’ll still work just fine).

    You can even type out your paragraphs before-hand, and then click ‘spoiler – and it will insert the spoiler tags, whilst still maintaining the highlighted text!

    Which is…
    Which is AWESOME!

    (Now, it doesn’t necessarily jive 100% with standard WordPress coding for editor plugins…. but… as long as it works, we can totes use it!)

    So somebody please give it a whirl, and let me know what you think. 😎

    It works but…

    Some pages doesn’t render BBCode. For example, in Activity>Mentions there is a post preview, and spoiler BBCode was rendered a simple text. It happens on other feeds too, for example, see my activity by clicking on “Jesusalva” at left.Other than that, it is great! 😀

    (Do not think in adding a “tabs” button, I can’t even imagine how that would look. If you want to save more page space, maybe Attachments section could be reworked, so “Submit” button is closer to the textarea.)

    @msg-commander Sorry for not responding earlier, the email just got drowned in an ocean of Gitlab broken pipelines D:

    License checks are truly annoying pipelines.

    NOOOOOOOOOOOOOOOOOOOOOOOOOOO!!!!!!!!!!

    Lolz.

    That was one of the very few things I never thought to test for haha. It is a mobile-only problem, because on my desktop those “Copy Share” etc buttons don’t appear at all.

    I think I could possibly fix that problem by re-arranging the buttons, and putting spoiler where the list buttons currently reside (but then they would be blocked, but that might not be as big of a problem), or I could try removing some buttons so we still have one line but spoiler is off to the far right – but then if the “Copy Share” buttons appear differently on different phones…. well…

    I hate to put it on the user, but it might be that the best solution in this scenario (assuming someone wanted to add a spoiler to their first line of text), might be to just cut the text, add the spoiler tags, and then paste the text back in between them? I hate having to offer a solution like that, because it makes more work for the user, but I really can’t see any other solution… (but by and large, it might not be that big of an issue, anyway… depends on how often people want to spoiler that first line of text.)

    Anyway thanks for bringing it to my attention.

    So…. if I quote an earlier post, and I’m on the “Visual” editor – it strips out all the paragraph tags.

    But… if I’m on the “Text” editor when I click on “QUOTE” – then it pastes the whole dang quoted post in the text editor, with nothing but carriage returns in all the right places… which, if I THEN SWITCH TO “VISUAL” – translate perfectly into paragraph tags, to maintain the original format in all of its earthly splendor…

    So this has probably been happening for a long time now, and I never noticed because I never bothered to quote anything that was longer than one sentence… Now I’m a sad panda while I go away and try to see if I can sort this out…

    Follow us on Facebook, Instagram, and Twitter

    #27314
    Mastertrek
    Moderator

    I rarely made quotes but for me some things get wrong without editing(possibly my phone /browser fault) .

    Sometimes some words are duplicating or the text gets cut in half and I have to rewrite it again. Or aragraphs sometimes didn’t want to work the first time.

     

    Welcome 😇

    • This reply was modified 6 months ago by  Mastertrek.
Viewing 4 posts - 11 through 14 (of 14 total)

You must be logged in to reply to this topic.

Forum Statistics

Members: 1,539 Forums: 119 Topics: 1,224 Replies: 8,241