Forums Kemco Games Rideon Marenian Tavern Story How to destroy large rocks?

This topic contains 7 replies, has 4 voices, and was last updated by  Mastertrek 1 day ago.

  • #30880
    finilain
    Participant

    Hi, I feel like I am probably missing something obvious, but I am stuck and would really, really appreciate your help.

    I have finished the main story today and am trying to complete my encoclypedia. I can’t access a lot of places due to large rocks (with cracks) being in the way. There has to be some way to destroy them, but I really don’t get how. I don’t have any skills or items I can use on them.

     

    I would be very happy if someone knows the answer!

    #30881
    Luther
    Participant

    After u finished the main story, there are 2 main story left which u need speak to bellina, she want u to go to Heath to bring her a hammer and after u go to Smith and speak with him he will give u hammer and pickaxe, that’s pickaxe is for break a stone. Hope this will help.

    #31870
    Judana
    Participant

    I finished the main story but Bellatina wont say anything else but how she trains her muscels next….

    Do I have to complete the 2 other stories before talking to her? How do I trigger the other stories..?

    I feel so lost in the game right now. I got the „clear data“; I talked to every citizen; I leveled Bellatina up to 99, try to achieve everything but nothing triggers anything.

     

    #31889
    Luther
    Participant
    #31892
    Judana
    Participant

    Mh ty…

    Im missing the False God Toto 2 part. This helps me as I now know where the problem is. Whats still weird is, that I fought twice against toto (successfuly) and I still dont have the achievment…. 🙁   is it because I use the switch version? I will try the fight again… hoping it will work this time.

    I mean I did not even get the ring of healing nor the greed ring from the fight (eventhough I saved and got the clear data)

     

    #31893
    Luther
    Participant

    hm… I don’t know about that. I use Android phone to play, then a bug?

    #31894
    Judana
    Participant

    Okay I know finally solved the problem. I dont know what the problem was in the end. I had to defeat toto three times in total. Everytime I got the clear data nothing happend. I did not have the items from the fight nor the story achievment. It was as if the fight (s) didnt even happen.

     

    This time I did not overwrite my normal game slot- I just used an empty one (if you know what I mean)On my second slot it now worked. I appeard in the tavern and not in the cave and had the items + the story achievment and can finally go on.

    Ty for all the help. I will post this in my other thread too, hoping I can help as many people who have to face the same bug.

     

    As I said I play on Switch maybe its because of that and the solution was either beating toto 3 times OR and this is what I ultimatly think : Dont safe on your normal game slot use and empty one.  So just dont overwrite ur old save just save by creating a new one.

    Now I can finally speak to heath and I will make sure all the rocks get out of my WAY! 😀

    1 user thanked author for this post.
    #31958
    Mastertrek
    Moderator

    So it was probably a glitch (I doubt KEMCO would make something like that intentionally..)

    Welcome 😇

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Forum Statistics

Members: 1,732 Forums: 122 Topics: 1,292 Replies: 8,658