No sounds

Written by Zherk01

Forums Kemco Games Magitec Soul Historica No sounds

This topic contains 11 replies, has 5 voices, and was last updated by Profile photo of Jesusalva Jesusalva 5 months ago.

Viewing 10 posts - 1 through 10 (of 12 total)
  • Author
    Posts
  • #18947
    Profile photo of Zherk01
    Zherk01
    Participant

    I played this for a bit before, great sprite based graphics, interesting story and the soul cage system is nice but then I dropped it because there is no sound in the game. I have the sound turned on and have my system and game volume at max. I just can’t play a game especially an rpg without bgm and battle sound, just not the same imo. Anyone else have this issue? Is there a way to fix this? I tested this on 3 phones and 1 tablet.

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Unlucky Hero

    Disliked: Asdivine Dios | Fairy Elements

    #18949
    Profile photo of famouscrystal1417
    famouscrystal1417
    Participant

    To tell you the truth that was also same to me,so i didn’t think SH(soul historica has any BGM and battle effect music) maybe it just has background music

    This one is telling the
    1.truth(lies)
    2.lies(truth)

    #18950
    Profile photo of Zherk01
    Zherk01
    Participant

    Bummer as this is really a pretty decent game. Also, BGM means background music. XD

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Unlucky Hero

    Disliked: Asdivine Dios | Fairy Elements

    #18952
    Profile photo of LemmyTheLenny
    LemmyTheLenny
    Participant

    Maybe the sound slider was inexplicibly set to 0? I play my games with the sound always off since i’m usually playing kemco games on my phone in public so you’re better off keeping the soundoff.

    We don't make mistakes. We just have happy accidents.

    #18953
    Profile photo of Zherk01
    Zherk01
    Participant

    I already messed with the settings, nothing works. Maybe Magitec forgot to tick something on their engine. I do game development as a hobby and usually turns the sound off on my engine when I’m testing.

    I’m playing it sparingly, the game is really good but I can’t get immersed without bgm and battle sounds. Its just me growing up playing nes and ps games on tv with always high volume. Hahaha.

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Unlucky Hero

    Disliked: Asdivine Dios | Fairy Elements

    #18955
    Profile photo of famouscrystal1417
    famouscrystal1417
    Participant

    Well let’s gave it a miss then!

    This one is telling the
    1.truth(lies)
    2.lies(truth)

    #18965
    Profile photo of kamentierr
    kamentierr
    Participant

    i just tried the game and the sound is coming just fine on my device. It’s an old device though, 2013 with KitKat. So the problem might be that the app is not optimized for newer devices. There is also an option to turn off the sound in the option menu, that might be your problem.

    Btw, the battle theme is pretty good, a bit loopy but good.

    What an ass...

    #18968
    Profile photo of Zherk01
    Zherk01
    Participant

    I already messed with the settings like I said before but I’ll try installing it on a kitkat phone, I’m sure I still have my old phone somewhere though I’m not too optimistic if it does work there as the battery is already failing on that phone.

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Unlucky Hero

    Disliked: Asdivine Dios | Fairy Elements

    #19040
    Profile photo of Zherk01
    Zherk01
    Participant

    @rimrazan, finally figured out why it doesn’t have sound. I installed it on my old kitkat phone and at first it also doesn’t have sound so I messed up with the volume settings. Android have 3 types of volume: System volume(for apps and games), Call and Alert Volume and Alarm Volume. For some odd reason Soul Historica l’s volume can be adjusted only with the Call and Alert volume instead of the System Volume. In other words don’t set your phone in Silent Mode if you want to play Soul Historica with sounds. Stock kitkat android have a volume slider for each volume so its easily adjustable there but 5.0 and above you have to set your sound profile or just go to your homescreen and adjust the volume with your volume button there. Just make sure that you’re not on Do Not Disturb mode.

    Favorites: Blood of Calamity | Chronus Arc | Band of Monster | Machine Knight | Djinm Caster | Unlucky Hero

    Disliked: Asdivine Dios | Fairy Elements

    1 user thanked author for this post.
    #19165
    Profile photo of Jesusalva
    Jesusalva
    Participant

    Android have 3 types of volume: System volume(for apps and games), Call and Alert Volume and Alarm Volume. For some odd reason Soul Historica l’s volume can be adjusted only with the Call and Alert volume instead of the System Volume. In other words don’t set your phone in Silent Mode if you want to play Soul Historica with sounds.

    This is why I hate Magitec. They never get the sound channel right >.<
    Had the same problem but was trying Shelterra the Skyworld.
    Thanks for the tip. It worked. >.>

    Well, at least on Chrome Wolf they got the sound channel correct. So I believe Magitec games older than 2013 will/may have this issue too.

    Jesusalva / Jesusaves

Viewing 10 posts - 1 through 10 (of 12 total)

You must be logged in to reply to this topic.